RX 5 Audio Editor System Requirements

Latest version: RX Audio Editor 5.02 released August 9, 2016.  

Both RX 5 Audio Editor and RX 5 Advanced Audio Editor can be used as a standalone audio editor, as a standalone audio editor connected to your host via RX Connect, or as a suite of plug-ins.

Operating system requirements

  • Mac OS X 10.8 - 10.12
  • Windows 7, 8, and 10

Plug-in formats

Audiosuite DPM & AAX, AU 32 & 64 bit, VST 2 32 & 64 bit, RTAS 32 bit, AAX 64 bit

Plug-in host compatibility

Pro Tools (10 - 12.3), Nuendo 6.5, Media Composer 7.0.4, Premiere Pro CC 2015, Final Cut X, DaVinci Resolve 12, Media Composer 8.4.1, Audition CC 2015, Logic Pro X, Cubase 8.0, Sony Sound Forge 11+

©Copyright 2001-2016, iZotope, Inc. All Rights reserved.
License Agreement | Privacy Policy