RX 3 System Requirements

RX 3 runs as a standalone application, or as a suite of plug-ins for your DAW or NLE.

Operating system requirements:

  • Windows: XP (32-bit Service Pack 3), 7, 8 
  • Mac: OS X 10.6.8 or later (Intel only)

Plug-in formats:

AAX (Pro Tools 11), RTAS/AudioSuite (Pro Tools 7.4-10), VST and VST 3, Audio Unit

Host compatibility:

In addition to being available in RX 3's standalone mode, RX 3 modules are also compatible* as plug-ins for popular hosts like Pro Tools, Media Composer, Cubase, Nuendo, WaveLab, GarageBand, Logic, Final Cut Pro, Premiere, Audition, SONAR, ACID, Vegas, Sound Forge, Ableton Live, and many more.

*Please note: the Spectral Repair plug-in is not a real-time plug-in, and therefore is not compatible with some hosts. List of compatible hosts

Reasons to Upgrade

See five reasons why you'll want to upgrade to RX 3 and RX 3 Advanced.

Get Support products audio repair small icon white

Have questions? We're here to help. Browse our educational materials online, or contact our Support Team directly.

Try Free for 10 Days

We want you to hear what iZotope can do for your sound, that's why every iZotope product has a free 10-day trial. Try for yourself today.

©Copyright 2001-2014, iZotope, Inc. All Rights reserved.
License Agreement | Privacy Policy