RX Loudness Control system requirements

Latest version: RX Loudness Control 1.03 released August 9, 2016.

Operating system requirements

Windows: 7, 8 and 10

Mac: OS X 10.7-10.12

NOTE: We are currently in the process of qualifying our most current products for Mojave 10.14 support. At this time, we recommend that our community wait to update to ensure the smoothest possible experience with our products. More information on Mojave support will be available very soon.

Supported plug-in hosts

Media Composer 7.0.4 and 8.3.1, Premiere Pro CC*, Pro Tools 10-12.  

*Although we support CC 2015, you will have to manually move the presets from the old location to the new location in order to load them. Additional host support is under development. 

Supported plug-in formats

Adobe Extension for Media Encoder CC, Adobe Extension for Premiere Pro CC, and AudioSuite DPM & AAX.